Need help integrating Rider with TFS Azure DevOps source control

I've downloaded Rider to see what it's like, and I've opened an existing solution that is currently under source control (TFS/Azure DevOps server). In Rider's VCS->Enable Version Control Integration dialog, there wasn't an option for TFS/DevOps, but I figured that I had to install the "Azure DevOps" extension which added a "TFVC" entry to the list. Initially it complained that it couldn't find the TF command line, so I downloaded "Team Explorer Anywhere", and in Rider's Settings->Version Control->TFVC, I've selected the "tf.cmd" file for the "Classic TF command-line client" option. Is this correct so far?

Now, when I go into VCS->Enable Version Control Integration, and try to enable "TFVC", I see a couple of messages appear briefly ("Looking for TFVC workspaces", "Loading TFVC workspace"), followed by an error in the corner of the Rider window: "Couldn't create TFVC repository in C:\... - EULA not accepted". What am I doing wrong?

On a related note, as the solution is already under source control, does Rider utilise the existing *.vs**cc files and the various scc entries in project and solution files, or does Rider have its own equivalents of these? If so, will it screw up any of the Visual Studio source control integration settings if I was to subsequently open this solution in VS2019?

 

2 comments
Comment actions Permalink

I've got a bit further. I had to run "tf eula -accept" in a command window, but also had to install Java first. Not the most intuitive of things to set up so far!

I've hit another problem now though. Rider doesn't seem to recognise that the solution is already under source control. If I attempt to edit a .cs file I get a "Clear read-only status" dialog but only the "Using file system" option is available. I'd also expect to see status icons in the "solution explorer" window showing files' source control status (checked out, new, etc). How can I fix this?

I've tried restarting Rider but it makes no difference. I'm also seeing a new warning at startup: "Cannot determine version of TF command line client".

0
Comment actions Permalink

So after another restart it now seems to be working. I'm not keen on the use of text colours rather than icons to indicate source control status, but hey ho.

1

Please sign in to leave a comment.