when i run 2 microservices at the same time, the break points of the first one gets disabled.

when i run 2 microservices at the same time, the breakpoints of the first one get disabled and i can't debug 2 connected microservices at the same time.

is there any settings for it or its a bug of rider?



Hello, would it be possible to share a small video showing the issue, share if you get any error when it happens to make it a bit more clear? Thank you in advance!


To debug multiple services at the same time you switch between the active debug configuration by selecting the console for that debug configuration.  In the following screenshot I have 2 microservices being debugged and a web application.  Note Cyril microservice is selected and it shows the breakpoint in the web service as disabled.

To enable the breakpoint I just have to select the web application as the active debug source:

Hope this helps.





Thank you for the reply. When there are several debug sessions running then we show information for the current debug session. Rider runs separate debug worker for each process. That is why Rider shows breakpoints from another service unbound because they are not in the current process. When you change the focus or hit the exact breakpoint, then the required dll is loaded into runtime.


Please sign in to leave a comment.