Project files not showing in Rider's Solution Explorer

I'm running Rider 2022.2.1 on MacOS 12.5.

In one of my projects I am unable to see my project files in the solution explorer.

 

If I enable "Show All Files" I can see the files and they are marked as included

 

I do see the files if I search through "Navigate -> Symbol..." too.

The project uses the newer project file format that can target multiple frameworks. If I re-create the project using the legacy format that can only target a single framework the solution explorer shows the included correctly.

I have tried "File -> Invalidate Caches..." with all of the boxes checked. This didn't fix the issue.

This issue occurs when the project is added to a larger solution with many other projects as well.

Is this a known issue or is there a way to fix this behaviour?

Thanks

3
7 comments

Hi mbaker

Could you please share your .csproj file with us? You can upload it to our server privately and share the ID. 

Thanks! 

0

Thanks for the response Alexandra. I've uploaded the whole project/solution.

Upload id: 2022_09_02_v4mzxUytmnjKHpnVJLhCoU (file: anvil-csharp-logging.zip)

 

In case it helps you can find the project, in context, here:

https://github.com/decline-cookies/anvil-csharp-core/tree/9c293558f83f4042d094391360303ecb857ed766/Logging/.CSProject

 

I'm not sure why I blacked out the info in my screenshots originally... this is all publicly available.

0

Hi mbaker!

Thank you for the details. I was able to reproduce the case and created an issue for it. Our team will process it soon. Feel free to follow the issue for updates. 

Should you have any other questions, let us know. Have a good day! 

0

Great, thanks Alexandra!

0

Hi there, 

I have the same issue on Rider 2022.2.4 on windows: 

Build #RD-222.4459.9, built on November 4, 2022

Licensed to Eugene Shevchuk
Runtime version: 17.0.5+7-b469.67 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.

.NET 6.0.6

Did you guys fix or tell how to fix this ASAP? This is really inconvenient for the work

Alexandra Guk, FYI.

 

Kind regards,

Evgeny

0

Hi Eugene S.

Please upvote the mentioned issue. Do you have this issue on Rider 2022.3? 

0

Hi All,

Maybe it'll help someone:

If you are having this issue, check if you see siren-looking IDE Errors icon at the bottom bar.  There might be an error that can give you a good idea of what is causing it.

Just had this issue on Rider 2023.2.2, with AtomMaterial plugin - I had customized icon for one of the projects in solution via AtomMaterial plugin, and probably messed up the file path, so after IDE restarted few projects in the solution view went missing.  Took me a while to spot that “IDE Internal Errors” Icon at the bottom was red.  Looked inside and there was  FileNotFoundException caused by MaterialIcons.  

Good Luck,

Oleg

 

1

Please sign in to leave a comment.