Trying to Evaluate Rider with Unreal 5.03 - Not even sure it is supported?

Has rider been properly released for Unreal 5.0x and if so where do I find the details.

The official website says very little about unreal 5.0 support and if I try and search for Rider and unreal 5.0 I keep getting directed to a video of the Early access version of Rider which I can’t even see on their website.

I’ve not used this product before so am a bit perplexed to how this is supposed to work

I did install the 30 day trial version (which doesn’t mention anything about unreal 5.0 ) but it did try and automatically install a linker plugin for the Unreal 5.0 engine which failed.

After a reboot I tried a 2nd time and the installation worked. 

I have configured Unreal 5.03 to work with the Rider (Uproject) , unreal reloaded and I have attempted a compile of a test project and it worked. 

There is literally no documentation on the correct sequence of steps for installing this from scratch apart for some out-of-date YouTube video talking about a early access version which isn't available for D\L?

I keep hearing how wonderful this IDE is for Unreal but so far, I am not impressed with its documentation especially in regards to the vagueness of what version of Unreal it supports. if I am to buy Rider I would like clarification on whether this is a full supported release or still in early access which should be using for experimentation only.

3 comments
Comment actions Permalink

Hello Jeremy,

Thank you for your time spent leaving the feedback.
Indeed, Rider supports UE5. Preview is ended now and the only version of Rider you can install is regular Rider. We agree with you that this video is outdated. We will update it with a new one later.

You probably encountered the known issue with RiderLink installed to the Engine. Regrettably, the only option to use RiderLink with UE5 is to install it to the game. Otherwise, it causes compilation issues. We have this third-party issue on our tracker.
You can track the current status on the issue page.

Would you mind verifying if you have it under "{UE_InstallationPath}\Engine\Plugins\Developer\RiderLink"? If it is there, try moving the RiderLink plugin from Engine to the game project in one of the following ways:

  • Open game project in Rider and select "File | Settings | Languages & Frameworks | Unreal Engine | Install RiderLink in game"; It should move RiderLink from Engine to Game;
  • If it doesn't work, please delete RiderLink from Engine manually (delete the {UE_InstallationPath}\Engine\Plugins\Developer\RiderLink folder); then install RiderLink again via "File | Settings | Languages & Frameworks | Unreal Engine | Install RiderLink in game";

If it doesn't help, would you mind sharing the compilation errors you encounter?

Thank you in advance and have a nice day!

0
Comment actions Permalink

Hi, 

I'm not exactly sure how I fixed this but after reinstalling the linker a second time and restarting unreal it seems to be working properly at least for the current project I ‘m studying. 

I’m mostly a hobbyist and I’m relatively new to unreal though not with coding in general.

I really just want a IDE that can be used easily with Unreal as I’m not sure if Visual studio 22 is good enough as I was having some issues though it’s been behaving itself for the most part recently

I’m not really clear on what regular rider means, I just wanted to use something that properly supports Unreal 5.0 as I'm trying to learn unreal 5.x and don’t want to get bogged down with issues with IDE bugs.

Is Rider really ready for Unreal 5.0x  or should I be looking at something else?

0
Comment actions Permalink

Hello Jeremy,

Apologies for the confusion. Earlier, during the early-access period, there was a dedicated build of Rider called "Rider for Unreal Engine". Starting from Rider 2022.1 release, "Rider for Unreal Engine" is released and completely merged with "Rider" product (which I called regular Rider). The preview period for "Rider for Unreal Engine" is ended. Now it is released (as part of "Rider") product and yes, Rider is ready for Unreal Engine 5.0x

Should you have any questions or anything is unclear, please let me know.

 

0

Please sign in to leave a comment.