The breakpoint will not currently be hit. How to associate different versions of the engine?

I have multiple versions of the engine on my computer, the launcher version, the early_access version and the 5.0.2 source version, and when I breakpoint it doesn't hit properly.

It still hits the early_access version when I use the 5.0.2 version, which is the problem I'm having. Is there any workaround, change the configuration or something, instead of deleting an engine.

Looking forward to everyone's answers, thanks a lot!



Thank you for contacting Rider support.
Would you sharing the additional information as described below?

  • what the operating system you use?
  • the way you open your project (.uproject, .sln, .uprojectdirs);
  • the value of EngineAssociation field in the .uproject file of problematic project;
  • does the early_access version is installed from launcher or built from sources?
  • do you have "Editor symbols for debugging" installed for engines from launcher?

Thank you in advance!


Thank you very much for taking the time to help me with my problem, here are some additional details.
I am using a windows system with the project opened via 'sln'. Before running the project, I used the right-click menu to switch the Unreal Engine version, so the EngineAssociation should have the correct engine version number.
The Early_access version is also the source version of the engine. I did not configure the pdb separately in Rider or elsewhere, and the breakpoints worked fine in VS, and the problem occurred after using Rider.

This is exactly what happens, the file in the 5.0.2 engine in Rider does not get hit at the breakpoint, but then I drag the same file from the early_access version of the engine into Rider and it gets hit.

I hope the information is useful and thank you very much for helping me to solve this problem.



Thank you for the details shared. 

So, you open game project that targets 5.0.2 source engine, place breakpoint in engine code (let's say Actor.cpp) but breakpoint doesn't hit, right? Does Rider show any error next to breakpoint? How exactly you make Rider to hit on breakpoint?
Are you just dragging the copy of this file from early_access engine folder into Rider editor?

Could you please try invalidating caches for problematic project (File | Invalidate Caches)?
If it doesn't help, would you mind sharing the following details with us?

  • Enable `Debugger` trace scenario via `Help | Diagnostic Tools`;
  • Reproduce the issue (breakpoint can't be hit -> you dragged the file from another engine to Rider);
  • Please write down the timespamps for both events)
  • Collect Rider logs via `Help | Collect Logs`;
  • Do not forget to disable the trace scenario enabled;
  • Please upload the archive generated to the Upload Service and let me know the Upload ID.
I will be waiting for your response. Have a nice day!

Would you mind also trying to rebuild the project via `Build | Advanced Build Actions | Rebuild Current Project`


I'm sorry to reply to you so late, after asking this question, I also searched and tried many solutions, but none of them solved my problem, after many attempts to solve this problem did not work, I finally had no choice but to delete the early_access version.
After deleting it, everything was back to normal.
So I can't reproduce the problem anymore. I'm not sure if this is just a personal problem for me, and it's probably rare that people install multiple source engines, so I'll give some details here that I think will help if you're still concerned about this issue.

  • The files I breakpoint are mostly files under "Engine\Source\Runtime", I will operate in the engine to trigger the logic of the breakpoint file.
  • I rebuilt the project several times and also tried deleting the "Intermediate" and "Binaries" folders before rebuild.
  • The breakpoint does not prompt additional errors, the only thing displayed is "The breakpoint will not currently be hit. No executable code is associated with this line."
  • The idea of dragging another engine's file into Rider came up because I saw a solution on the web which stated that moving the rider and engine to the same disk would solve the problem, so I tried dragging another engine's file into Rider and it did hit.

That's all the details I can think of for now, my problem was solved by removing the extra engine, so I may not focus on this issue anymore, thanks a lot for your many help!



I am happy to hear that the solution was found.
Should you have any other questions or difficulties in the future, do not hesitate to contact support. Have a nice day!


Please sign in to leave a comment.