Color Scheme doesn't work for one exact solution

Hello!

I just stared using Rider and in one of the solutions Color Scheme doesn't work for C# code. Though it works fine for .xml or .sql files or even in IL viewer but not for .cs. Also, works for C# code in other solution.

Any suggestions? I tried to make changes in Color Scheme and Restore Defaults but that didn't help.

1
10 comments

Hi Kappakeepo4header

It seems like analysis could be switched off in this solution. Could you please check if there is an OFF sign on the top-right of the editor tab? Please try to switch Highlights to All problems. Thanks! 

0

Hello, Alexandra! Thank you for reply.

I already have tried to set this setting to different modes - it didn't work. Even more, code style suggestions works fine, but not the coloring :(

I also tried to Invalidate caches and delete .idea, .vs and _ReSharper.Caches folders from the solution folder.

When I cloned same repository from the VCS to another folder - problem was gone, color scheme worked.

0

Hi Kappakeepo4header

I see. If the issue occurs again, could you please add a screenshot of the full Rider window, with one of such files opened and Solution explorer visible? 

Thanks! 

0

I finally figured it out. Deleting file *solution*.sln.DotSettings.user helped.

I guess there was a conflict with ReSharper settings because I've been using VS 2022 + ReSharper before Rider.

1

Hi, I have the same problem. 
After reading this I found solution. as it seems rider is getting confused by settings ment for visual studio. And I think the setting that causes it is “Use the Color Identifiers”.

Alexandra Guk please verify and create bug for it. 

0

Hi Mikolaj R

Thank you for the report. It was a while since the thread was started. The setting you mentioned exists both in Rider and ReSharper settings. What version of Rider, ReSharper and Visual Studio do you use? Do you work with the solution simultaneously in Rider and VS? 

I'll try to reproduce the issue on my side. Thanks! 

0

Hi Alexandra Guk ,

The issue is related to using VS 2022 and Rider 2023.3.2 on the same solution. 

Because Rider doesn't have xaml hot reload, it has to share… 

Another problem is that Resharper is not picking up custom colors set by the user, so I have to turn of this feature to have readable code in VS. However, when I turn it of for Resharper, Rider is picking it up and is unusable that way. 

0

Hi Mikolaj R , thanks for your reply.

Another problem is that Resharper is not picking up custom colors set by the user

Could you please describe where you're changing colors: in Visual Studio or in Rider? 

However, when I turn it of for Resharper, Rider is picking it up and is unusable that way. 

This is expected behavior, since Rider can read ReSharper settings files. Therefore, if in .DotSettings file “Use the Color Identifiers” option is turned off, then this value is read by both ReSharper and Rider. Let's first try to understand the problem due to which you need to turn off “Use the Color Identifiers” option.

Thank you!

0

I have this problem and tried everything discussed here and still have this. I even deleted the entire Rider with all config files and cash in projects - still there. Even create new project still color scheme is grey for C#.

Btw C++ files color scheme work correctly.

0

Hello Makuta Vitar, thank you for your question. 

Do I understand correctly that you have "File | Settings | Editor | Inspection Settings | Highlighting | Color identifiers" option enabled?

Could you please attach a screenshot of the whole Rider window including the indicator in the upper right corner (with a hover tooltip message there)?

Also, please upload Rider settings to JetBrains server: File | Settings | "Manage Layers" button at the bottom => "Export to File" in the context menu for each layer. I will try to reproduce the behavior with your settings, and hopefully, we can pin down the root cause of the issue. Thank you!

0

Please sign in to leave a comment.