Color Scheme doesn't work for one exact solution


I just stared using Rider and in one of the solutions Color Scheme doesn't work for C# code. Though it works fine for .xml or .sql files or even in IL viewer but not for .cs. Also, works for C# code in other solution.

Any suggestions? I tried to make changes in Color Scheme and Restore Defaults but that didn't help.


I finally figured it out. Deleting file *solution*.sln.DotSettings.user helped.

I guess there was a conflict with ReSharper settings because I've been using VS 2022 + ReSharper before Rider.


Hi Kappakeepo4header

It seems like analysis could be switched off in this solution. Could you please check if there is an OFF sign on the top-right of the editor tab? Please try to switch Highlights to All problems. Thanks! 


Hello, Alexandra! Thank you for reply.

I already have tried to set this setting to different modes - it didn't work. Even more, code style suggestions works fine, but not the coloring :(

I also tried to Invalidate caches and delete .idea, .vs and _ReSharper.Caches folders from the solution folder.

When I cloned same repository from the VCS to another folder - problem was gone, color scheme worked.


Hi Kappakeepo4header

I see. If the issue occurs again, could you please add a screenshot of the full Rider window, with one of such files opened and Solution explorer visible? 



Please sign in to leave a comment.