How is to create a C++ project?

Answered

I have Rider 2022.2 on Arch Linux. From what I understand from IDE description, it should support C++ language, and I see C++ plugin in my installation, enabled by default. But I can't find a correct template in "Create new solution" menu. For example, in "console application" one I can only choose from C#, F# and VB. Am I missing something?

1
19 comments

My installation has a separate C++ section inside new solution:

Maybe it differs from version to version (I'm on Rider 2022.2)

1

Hello Griglogvin,

Thank you for contacting Rider support.
On MacOs and Linux, the only way to develop on C++ is to work with Unreal Engine projects. You can open .uproject and work on Unreal Engine project/engine, but there is no way to develop non-UE projects.

1
Hello Dan,

Thank you for your feedback.

Regrettably, I have no news regarding this. It is still not planned for any release.

Have a nice day!
1

Hello Gideon,

Non-UE C++ Development is available on Windows. You can work with .vcxproj/.sln based C++ projects by openning .sln file.

Have a great day!

1

Hello Gideon,

Do you mean that you need to launch a third-party application that utilizes your library?

You can create Native Executable run configuration for that purpose:

Does it help?

1

I have no such section... Looks like something is wrong with my installation then

0

At the risk of breaking a rule and necroing the thread. Are there any plans to add non-UE project support for C++ in Linux?

0
Hello Tuomo,

We have no plans to support non-UE C++ development on Linux or MacOS in Rider, but it might change in the future.
Have a nice day!
0

Necroing the thread again - I would like to add my perspective on non-UE C++ development. I used Rider for Unreal C++ at my last job and am now also transitioning to Rider for Unity C# for a new job - so far I have really enjoyed the Rider experience and am considering subscribing for personal use as well. 

I have a hybrid setup with a Windows desktop for working from home and a Macbook for in-office work, and I want to avoid having to work in different IDEs on each platform. Especially when dealing with non-UE C++ projects, this dual-OS development is a bit problematic. I know that CLion would be the best option for this use-case - but I would prefer to work in Rider for all projects and operating systems without having to switch between IDEs - and since C++ already works in the specific context of Unreal, I still have hope that non-UE C++ will be supported in the future.

0

Hi, so is support for non-UE C++ Development already available on Windows? ... I use a windows PC and would love it if can use rider for C++ projects too, instead of VS and resharper

0

Ok … But the C++ Project Run/Debug Configurations only work for C++ Console Applications, It Doesn't work for the Static or Dynamic libraries.  

First off it doesn't auto set.And when i go to Edit Configurations and select the C++ project it doesn't run, i tried copying the configurations from the C++ Project in the Console Application but that doesn't work either… It Builds successfully but then goes “Error running ‘C++ Library’:” Is that an issue or am I just messing it up?  

0

Hello Gideon,

Would you mind describing your scenario in more detail and sharing additional information as described below?

  • What do you mean by running a C++ library?  Do you have a working project that you can't run in Rider, or do you experiment with project templates available in Rider? How do you usually run the problematic project?
  • Make a screencast that demonstrates the way you usually run your project.
  • Share a full-screen screenshot that demonstrates the issue.

You can upload screencast to the Upload service. (please let me know the upload ID)

Thank you in advance and have a nice day!

0

Hi, thanks for replying. I used a Rider C++ Library template : (I tried both the static and dynamic libraries). I did a bit of tinkering myself since I messaged last and I believe that Rider has issues locating the working directory in the run/debug configurations lemme itemize this so i don't miscommunicate :

  • First After creating a static or dynamic library it doesn't auto-generate run configurations
  • So I tried editing configurations and set it to the C++ project as shown in the image below.
  • But it still doesn't work : It does not identify a project to run nor does it select the correct working directory
  • so I tried : $(LocalDebuggerWorkingDirectory) but that doesn't help either … that's where I'm stuck at.
  •  But for some reason it works perfectly when I create the library in Visual Studio and open it in rider .
0

Hello Gideon,

Would you mind confirming if my latest post doesn't help? (see the message above yours one)

Have a nice day!

 

0

Yeah tried it but it doesn't work  

0

Hello Gideon,

Would you mind elaborating on your scenario then?

There is no way to launch C++ libraries as a standalone application because of C++ library design. C++ library is supposed to be used by another application. 

Static library is supposed to be compiled and packaged together with the application that is going to utilize this library. So, a copy of a static library is physically part of the executable.

Dynamic library is not a part of executable and is being compiled separately. It exists as separate files outside of the executable file. Such a library is being loaded and linked to your executable during the runtime.

I also verified the behavior in Visual Studio. It allows “Running” the project, but the following error occurs:

What is the behavior you are trying to achieve and why the Native Executable run configuration option doesn't help? You need to set Exe path field to the .exe that is going to utilize your library.

Have a nice day!

0

Is adding C++ VCXPROJ available on Rider 2023.3.4? I didn't see any C++ project related thing there. I'm on Ubuntu 22.

0

Hello samm.tan,

.vcxproj projects are only available on Windows and depend on MSVC/VS Build Tools to build the project.

0

Well that explains everything. Thanks for the answer.

0

Please sign in to leave a comment.