"The breakpoint will not currently be hit. No executable code is associated with this line." Rider, Unreal Engine 4.27

Hello -

I'm seeing the error in title, and breakpoints are greyed out in several of my .cpp files - but not all of them.

This happens to be an Unreal Engine project, but I don't think that's relevant. The files are all in the game side, not the Unreal Engine side, and are all in the same directory, on non-removable storage. (Responding to the comments in https://rider-support.jetbrains.com/hc/en-us/community/posts/5303267544466-Cannot-set-breakpoint-ue-5-0-1-rider-2022-1 and https://rider-support.jetbrains.com/hc/en-us/community/posts/7144909388690-The-breakpoint-will-not-currently-be-hit-How-to-associate-different-versions-of-the-engine-)

  • Rider 2022.2.2, Build #RD-222.3962.23, built on August 20, 2022
  • Windows 10
  • Unreal Engine 4.27 (custom source)

Problem:

Setting a breakpoint in FileA.cpp results in a circle-slash icon with the "The breakpoint will not currently be hit. No executable code is associated with this line." message.

Setting a breakpoint in FileB.cpp works as expected.

I run by hitting either F5 or the Debug button. I'm not using Live Coding (to my knowledge - I just installed Rider this week, still coming up to speed).

I tried using Run + attach to process, same result.

My theory is that the debug symbols are being stripped for some of the files in the executable - is that possible? Why? How do I fix it?

Thanks!

1 comment
Comment actions Permalink

Aaaaand, solved it - putting my solution here in case others run into it.

Switching from Development Editor to Debug Game enabled breakpoints in FileA.

0

Please sign in to leave a comment.