Messed up Colour Scheme

Answered

I have no idea how I've done it, but all of my code seems to have gained a background...

Well, I say all, Comments and a few other bits are OK, ...It doesn't matter what colour scheme I select, the effect remains, and I've hit "reset" more times than I can count.

How do I fix this?

4 comments
Comment actions Permalink

Hi Stuart Hemming

Does it happen in Razor files? Please check File | Settings | Editor | Color Scheme | ASP.NET => Code block | Background and disable it if necessary. If it happens in regular C# files, check the same Background settings in File | Settings | Editor | Color Scheme | Language Defaults => Classes | Instance Method. 

I hope this helps!

 

0
Comment actions Permalink

OK. Thanks Alexandra, but it wasn't that.

It's code coverage. It is the settings "Highlight Code" in the unit tests coverage window.

Switching that off and all is good.

I don't suppose you know how I can get the line markers to show without the highlights, do you?

Either way, thanks for taking the time to reply

0
Comment actions Permalink

Hello Stuart Hemming

dotCover highlighting is configured over there File | Settings | Build, Execution, Deployment | dotCover | Highlighting

Please also refer to [the documentation page on this matter](https://www.jetbrains.com/help/rider/Settings_DotCover_Highlighting.html).

Should you have additional questions or further assistance be required, please let me know. Have a nice day!

 

 

 

 

0
Comment actions Permalink

Alexander, that's just what I was looking for. Thank you

0

Please sign in to leave a comment.