Stop rider from adding braces or parens as you type

How do you stop Rider from "helping" and adding in characters as I type?

I type open parens (  and it adds in a closing one )

I type open brace {  and it adds a closing one

It screws up my code constantly, I don't look at the screen most of the time I'm typing and when I look back its all screwed up.

HINT to editor developers: If you have to HELP type code, your failing....please STOP trying to help, it is costing me money and time.

 

2 comments
Comment actions Permalink

FYI I already set "automatically insert parentheses after completion" to NONE, it does not obey its own settings.

 

0
Comment actions Permalink

Hello, try unselecting the option Preferences | Editor | General | Typing Assistance | Auto-insert pair brackets, parentheses and quotes. Let me know how it goes.

0

Please sign in to leave a comment.