Additionally installed project templates not showing under Other section

Answered

Hello, I am having issues with showing the additional project templates being installed.

Generally I have tried running the following command through the CLI for installing the NUnit 3 Test Project Template:

dotnet new --install "NUnit3.DotNetNew.Template"

But nothing is showing up in the New Solution dialog box under Other after successfully installing the package and to be honest I don't have Other section at all.
I have also tried to manually install the package via the nupkg file through More Templates and Install Templates and clicking Reload after import but still the same result.

Rider version: 2022.2.2
Build: 222.3962.23

P.S. I have installed and enabled Azure Toolkit plugin for Rider as I read in an article that it or Unity plugin needs to be installed in order to see the Other section but again with no result.


Thank you for your attention and time!


Regards,
Hristo

6 comments
Comment actions Permalink

Hello,

Could you please check if the installed template appears in the list when running: "dotnet new --list"?

0
Comment actions Permalink

Hello,

When running the following command through the CLI - dotnet new --install "NUnit3.DotNetNew.Template"

I am getting a message that it is installed successfully:


And after that I can see it as installed template after running - "dotnet new --list":

0
Comment actions Permalink

Hello,

thank you for the reply.

It happens that Rider bundles this template. Please try opening New Solution window | Unit Test Project | select NUnit.

You can see on "Project Template info" tab that it's "NUnit3.DotNetNew.Template"

Please let me know if you have any more questions.

0
Comment actions Permalink

Hello, thank you for your answer!

I can confirm that testing with Eto.Forms template works fine and is showing under Other section.

Regarding NUnit 3 Test Project Template when I create the project via the CLI with the following command:
"dotnet new nunit -n DemoProject"
I am getting a project created without a solution file like this:


And creating it through Rider has a solution file every time I guess? This cannot be avoided?


0
Comment actions Permalink

Yes, it's creating a new solution feature and a solution file is needed. It's quite a typical behavior as Visual Studio also creates solutions.

0
Comment actions Permalink

Yes I am familiar with the solution behavior in Rider and Visual Studio.

Guess only the project without a solution file is just a local project structure created from the NUnit 3 Test Project Template through the CLI.

 

Thank you again for your help and quick responses!

0

Please sign in to leave a comment.