Rider switches my windows keyboard layout--anyone know how to disable this?

Rider (and actually, the VS plugin as well) have this bad habit of changing my windows keyboard layout. I'm in a dvorak layout, and if I switch to Rider--AND RIDER ONLY--the keyboard layout will switch to a QWERTY layout that isn't even available in my Windows locale. I've removed all the QWERTY keyboard layouts; it's only possible to switch to a dvorak layout, from a UI perspective.

I had this problem with Visual Studio as well until I disabled a particular setting (https://stackoverflow.com/questions/484248/visual-studio-appears-to-randomly-adopt-american-keyboard-layout), but only after Resharper was installed.

It is NOT the keyboard input settings; I also have those completely disabled. 

This is incredibly irritating, because I usually end up accidentally editing files that I don't want to, or performing commands that weren't intended. Is there a way to disable this terrible behaviour? I couldn't find anything in the settings. If this keeps up, I'll honestly just uninstall Rider and Resharper; they're not worth this destructive behaviour.

2 comments
Comment actions Permalink

Hi Vincent, 

Sadly, I was not able to reproduce this issue yet. Please specify your Windows version and the list of the installed system languages.

0
Comment actions Permalink

Windows Version 10.0.19044 Build 19044

0

Please sign in to leave a comment.