Rider MacOs Hot Reload

switched from Windows to Mac(M1)... loaded my asp net core projects from Github, but cant use Hot Reload ...

i created a new project to check if there is the same problem but no... everything is working fine .. so something is wrong with my project... any ideas ? 

"There was an error in changes you tried to apply, Hot Reload was disabled for the current session. Please restart the session"


Hi Gunther

Are you on .Net 6? If so, there is no Hot Reload for now supported, unfortunately. Please let me know if you're on .Net 5. 



Hi Gunther! Did I understand correctly that cshtml Hot Reload works in a newly created project? Is there any chance you could share your initial project with us? I am still not sure that cshtml Hot Reload is properly supported. Thanks!



i made a shot screen recording of a new project.

cant show my other project because of privacy.


Hi Gunther

thank you for the screencast. Please add a screenshot of the error where you see it and also attach logs from `Help | Collect logs` after reproducing the issue. You can do it privately by using our Uploads service and sharing the ID.

What Run Configuration do you use? Is it IIS Express? 



ID: 2022_10_03_xrMCjFcZ3QCWLbPgFaYX3Q

No, "Launch Profil : Solution (Project)"


This is not strictly Hot Reload as I think Gunther does a refresh of his browser at the end there. I have a similar issue with a .net core 6 project with MVC, when I make changes on the view and I refresh the pages, the html changes will not show, yet when I do it in a new MVC project it works like Gunther's does. 


Hello Gunther, Pierre! 

Sorry for the misunderstanding.

Indeed, as Pierre said, this is not actually a Hot Reload. The described problem looks like a known issue for MVC projects. I've added your details and logs there privately. Please follow the thread. 


Hello Alexandra Guk,

and what about "real" Hot Reload? I'm on M1 and net6 and there's no hot reload available. Is there any option to enable it or it's not ready yet?



Hello Denis,

In general Hot Reload should work on Mac M1 (.NET 6) in Run mode but not in Debug. (for debug, please upvote this issue) . Also, it doesn't yet work in Blazor WASM projects.
If you have Hot Reload not working in Run mode in your project, please submit a new request from here and clarify your project type.

Thank you in advance and have a nice day!



Hot Reload don't work on mac os (macbook pro m1 16). 

IDE: JetBrains Rider 2022.3.1

Project: asp.net core mvc . Created by Rider IDE.

Use case: I change header text in _Layout.cshtml. Then I Click on "Apply Changes". And I get error. See screen shot.


Hello Valera,

This is a known issue and we have it reported on our tracker. I updated the issue with details. We would appreiate it if you could upvote this issue to demonstrate your interest.

Have a nice day!


Please sign in to leave a comment.