Docker compose in separate Rider instances don't run

I have 2 Rider instances open.
Each one is a separate solution entirely.
In both, I've setup a Docker Compose configuration to run, with the following arguments:
- Build: Always
- Attach to: Selected Services

When run with only 1 instance of Rider open at a time, each Docker compose starts the container that it should start.
But when I have both the instances of Rider open, if I start one Docker compose, then that one builds and runs just fine. But then if I go to run the compose through the other Rider instance (it's a different container and solution entirely), then it stops the container I ran in the other instance, and rebuilds that previous container again - not the one relating to the solution I have open.
I've tried setting up separate docker servers, a bunch of argument changes and all - I've tried googling it, but nothing.


Hello Aidan,

Any chance there different containers in different solutions have the same name? Would it be possible to share a repro solution, that we could check on our side? You can upload it privately to our tracker with a new issue.


Thanks for the response.

The 2 containers are called different things:
OperatorInterface.API & DataApi.API


Unfortunately, due to company policy, we're likely unable to upload the repro solution. 

I might be able to supply parts that are required.

We're using an external docker network, and also using 2 compose files - in this case, docker-compose.yml & docker-compose.override.yml - both of these are linked in the configuration.

It may make a difference that I'm using the new Rider/IntelliJ UI preview.

Apart from those things above, its your average docker-compose with different image names, and separate solutions.


Okay, I have created an issue on our tracker for further investigation: RIDER-85811. Please follow it here, because we might need some other information from you, the latest state will be seen there. 


Aidan, could you please attach your logs to the issue? It should be collected right after reproducing the issue via Help | Collect Logs.


Olga Diakonova apologies, I didn't see this message.

I've uploaded the logs to the issue of running the docker successfully in one instance, and then attempting to run the different docker compose through the other instance of rider. The rider instance that didn't behave as expected is the one I've collected the logs from. I've attached it to  RIDER-85811.

I also get an issue where when I do the above - if I go back to the original IDE after closing the one that was broken, then the original IDE is now broken - but in that when I try to run the docker compose, nothing happens at all. I've also attached these logs - these are called 'Logs Unable to run anything' as I couldn't think of anything more descriptive :)


Please sign in to leave a comment.