Can't turn off autoformat upon git commit

I noticed Rider applies some sort of formatting rules (e.g. remove blank line at the end of files) upon committing git changes. None of the following seems to affect this behavior:

  • I unchecked all "Before Commit" actions.
  • I disabled "Reformat and Cleanup Code" under "Actions on Save"

How do I turn off this behavior? Or is there a log I can check to debug it?

1 comment
Comment actions Permalink

Hi Zheng Li

Please check that you disabled `On save` settings in `File | Settings | Editor | General`:

 

I hope this helps! 

Should you have any questions, let us know. Have a great day! 

0

Please sign in to leave a comment.