MSB3823 starts occurring after installing Rider 2022.3

I am working on a solution containing some .Net Standard 2.0 and .Net Framework 4.8 projects.

After updating to Rider 2022.3, I start seeing this build error on a subset of .Net Framework projects.

  Microsoft.Common.CurrentVersion.targets(3262, 5): [MSB3823] Non-string resources require the property GenerateResourceUsePreserializedResources to be set to true.

So lists this solution, but it does not resolve the build problem:

Critically, if I build the solution from MSBuild (command line), I do not see this error. I also did not see this build error before the update to 2022.3.

I tried clearing the caches to no avail. Any thoughts/solutions?


I'm currently unable to use Rider due to this bug. One of the core libraries in my main solution will not compile under Rider, but works fine in VS2022

Edit: Found a workaround. None of this is actually required by the project, so I have it only applied to Debug builds

  <!-- Rider Workaround -->
  <PropertyGroup Condition="'$(Configuration)' == 'Debug'">

  <ItemGroup Condition="'$(Configuration)' == 'Debug'">
    <PackageReference Include="System.Resources.Extensions" Version="7.0.0" />

Found a workaround, this is dependent on also having VS2022 installed. Change the MSBuild version from the auto detected one (.net 7 here), to the VS 2022 MSbuild instance.


I have the same problem. I was developing an mvc/.Net framework 4.8 using Jetbrains Rider 2022.2.4 and after updating to 2022.3 it failed building. The problem resides on the MSBuild. Please help. Thanks.


Ed Eldy21, does chaning of toolset in settings help in your case? Does it help if you disable R# build in Preferences | Build, Execution, Deployment | Toolset and Build?


It doesn't change anything Olga Diakonova . Please see details below. 


We're also experiencing this issue where msbuild is happy but builds under Rider fail. Has there been any progress on a fix from JetBrains?

The impact is that Rider is unusable for the projects/solutions that have this problem.


Hi there,

We fixed the issue when Rider fails to build .NET Framework project because of the Microsoft.WebApplication.targets problem.


The fix will be available in the upcoming bugfix build (I hope). Please give it a try and let us know if it helps.


Hi there again.

If you experience the build issue, please call `Rebuild with Diagnostics` context action (Right click on a project > Advanced Build actions). Then collect all the logs via "Help | Collect Logs" and share them with us via attaching them to the youtrack issue comment, or via the service (Do not forget to let us know the uploads ID).


hello. i have this same issue with version 2022.3.3 and the latest 2023.1. i cant seem to get the error to go away which is rather frustrating. i'm stuck using visual studio until this is resolved.



What MSBuild version do you have selected in Preferences | Build, Execution, Deployment | Toolset and Build? If you switch to another version, e.g. supplied with Visual Studio, do you still observe the same behavior?


Referencing MSBuild from Visual Studio worked for me, however it would need a separate Visual Studio license even if MSBuild was installed from Build Tools for Visual Studio, without the IDE.

 Switching MSBuild version used to version 17.0 mentioned above worked for me perfectly.


Please sign in to leave a comment.