How To Manually Uninstall Rider ?

I can't uninstall rider. Hitting bin/uninstall.exe results in a popup error stating: 
'Uninstall hasn't detected folder of Jetbrains Rider installation. Probably uninstall.exe was moved from the installation folder: 

So I hit uninstall.exe from the directory... only to be told it doesn't exist.

hitting uninstall from programs results in same effect. 

hitting uninstall from toolbox results in same effect. 

I need to reinstall but hesitant to do so until it is all removed. 

4
4 comments

Unfortunately, it is a known issue. We work hard to find a fix. Feel free to follow the issue to be notified once it is resolved. You can install the latest Rider separately using JetBrains Toolbox as a workaround. We beg your pardon for the inconvenience.

0

Solution from here: https://stackoverflow.com/questions/75536394/pycharm-uninstall-unsucessful-uninstall-hasnt-detected-folder-of-pycharm-inst 

works for Rider too. After creating that empty IdeaWin64.dll, the uninstaller starts working.

6

I can confirm, adding an empty file named "IdeaWin64.dll" in the bin folder next to uninstall.exe works!

4

Wierdest hack ever. But also yes it worked for me as well. I had Rider 2021.1.2 and it refused to uninstall. This hacked worked. Create the empty IdeaWin64.dll file in the bin folder along side the uninstall.exe, and the uninstaller starts working.

0

Please sign in to leave a comment.