2 browser tabs open when a browser is opened from Rider

Whenever Rider open a browser it opens 2 tabs instead of 1. One tab is for the intended url and the other is on https://localhost:3001 (it's always this url)

This happens when:

- Debugging/Running an Asp.NET core application

- Clicking a link in Rider (in a console window for example)

- etc

This behaviour started a few weeks ago and is quite annoying. I tried to figure out where this https://localhost:3001 is coming from but couldn't find it.

It started when I was still using 2022.2 and is still happening after upgrading to 2022.3

This is what it looks like when I run an app called "WebClient"

Any help would be greatly appreciated


Hello thingone69, does it happen if you change browser? Could you please share the content of launchSettings.json for your ASP.NET app? Does it happen, for example, when clicking links on Quick Documentation popup? Does it happen only in ASP.NET projects or in others too? 


Hi Olga, this happens from any link inside Rider, including ones that aren't related to the project I'm running, such as links in the terminal window like in this screenshot. I even set my project to not open a browser when running but it still open the 2 tabs when I click any link in Rider.

It always opens the intended link and https://localhost:3001


thingone69, thank you for the reply, could you also specify if it happens with any type of project, not only ASP.Net? And if the issue happens in any browser? Could you please also collect the logs via Help | Collect Logs and send them to us with a new issue on our tracker so we could take a closer look? Thank you in advance!


This happens even with a new empty solution open (i.e. a solution with no projects)

When I changed the default browser to Google chrome it didn't happen. When I switched back to MS Edge (chromium) then it opened 2 tabs as described above.

I have the logs as requested and I'm sending it in a new ticket 


thingone69, if you change it to other browsers, does it happen too or only with MS Edge? Please send me the link to the issue once you create it.


As mentioned in my previous message. The problem didn't happen when I switched to Google Chrome. The issue is here https://youtrack.jetbrains.com/issue/RIDER-87962


Please sign in to leave a comment.