RiderLink prevents UE5 startup (Error with RiderShaderInfo.dll)

I'm trialing Rider right now. I tried to make it work with a UE5.1 Project. Rider installed RiderLink to the project.
When i try to load the project now, unreal produces the error message:

"Plugin 'RiderLink' failed to load because module 'RiderShaderInfo' could not be loaded.  There may be an operating system error or the module may not be properly set up."

and the loading fails.

I also get a corresponding windows error code 0xc000012f message (Win 10 Pro) error for the UnrealEditor-RiderShaderinfo.dll

How do i solve this?

3 comments
Comment actions Permalink

Hello Schubert,

Thank you for contacting Rider support.
We are sorry to hear that you encountered such a problem.

We would appreciate it if you could share the additional information as below:

  • Do you launch the Unreal Editor from Rider while encountering this issue or you try to launch the Unreal Editor from Rider?
  • Do you have the {Project}/Plugins/Developer/RiderLink/Binaries/Win64/UnrealEditor-RiderShaderInfo.dll file?
  • Logs from the C:\Users\ricky\AppData\Local\UnrealBuildTool\ folder;

Would you mind trying the following steps and letting me know if it helps?

  • Remove the RiderLink plugin from your {Project}/Plugins/Developer/RiderLink;
  • Open a project in Rider again;
  • Ensure that you can launch the Unreal Editor from Rider via the Run button;
  • Stop the execution;
  • Select File | Settings | Languages & Frameworks | Unreal Engine | Extract RiderLink in game;
  • Wait until the process is finished;
  • Launch Unreal Editor from Rider once and check if the issue persists.

If it doesn't help, please, share Rider logs collected via Help | Collect Logs;

Thank you in advance and have a nice day!

0
Comment actions Permalink

Hi,
additional information:

1) It doesn't matter if i start UE from Rider (e.g. using "Run"), or if i load the Project from UnrealEngine launcher (with or without Rider open) - in both cases it prevented the loading of the project in UE due to the error.
2) Yes the .dll exists in the files
3) the logs are here https://www.dropbox.com/s/pppottbxldz0mh3/UnrealBuildTool.zip?dl=0

I tried the reinstall method.

After reinstallation of riderLink, the compile of my project failed with some code 6 (i forgot to take notes), inside  Microsoft.MakeFile.targets
I did a restart of everything, tried created a new blank UE Project, installed rider link. It worked, Project could be started no issue. 
Then i tried the first project again and it also worked with no issue (compile and everything)...
So it seems to work now, and i hope it stays that way. But its pretty weird...

0
Comment actions Permalink
Hello Schubert,

Thank you for the details shared.
I am happy to hear that reinstalling RiderLink solved the issue.

Should you have any other questions or difficulties, or encounter a similar issue again, please let us know.
Have a nice day!
0

Please sign in to leave a comment.