Rider for mac flickers when using cmd + ` to switch between windows?

Seems to happen after I'd upgraded to 2022.3.

Open 2 or more instances of Rider and try switching between them with `cmd + ``.

It flickers between the instances rapidly.

Still happening in 2022.3.1.

on MacOS 12.2.



Thank you for contacting Rider support.

Regrettably, you encountered a known issue. We would appreciate it if you could upvote the issue to demonstrate your interest.

As a workaround, please try to add -Dsun.java2d.metal=false in IDE main menu Help | Edit custom VM options... and restart the IDE.

If it doesn't help, please let me know.
Have a nice day!


This doesn´t work for me. I am running Mac OS 13.1 and Rider 2022.3 (recently updated and worked before the update.). I am also Swedish and use a Swedish layout on the keyboard. I can switch between instances of the same application using "CMD-<" in my system, and it worked with Rider, too, before the update.

The workaround doesn´t work either.


Hello Mats,

Would you mind verifying if the issue persists for you in Rider 2023.1 by installing the eap version?

Thank you in advance and have a nice day!

Hello Dmitry,

I have installed EAP 5 of Rider and tried switching between two Rider windows with no luck. The problem still exists.

Have a nice one.


Hello Mats,

Do you mean that the windows doesn't switch or it switches when you press CMD+` but Rider flickers?

By the way, does it work fine if you press Window | Next Project Window (and/or a hotkey shown next to it (⌥+⌘+` in ReSharper(MacOS) keymap))?

Would you mind sharing a recording that demonstrates the issue to be on the same page? You can upload it to the Upload Service and let me know the Upload ID.



I cannot switch between Rider windows (solutions).

My keymap does not allow pressing combinations with backtick "`" because the CMD neutralizes the CAPS which I have to use for backtick. But every other Mac program lets me switch between windows with CMD+< , Rider too before the last update when I updated to 2022.3 from a 2021.x version.



Hello Mats,

Would you mind trying the following steps?

  • Open Preferences | Keymap;
  • Find the Main Menu | Window | Open Project Windows | Next Project Window action in the tree;
  • Right-click on it and select Add Keyboard Shortcut;
  • Press the desired keys combination and press OK;
  • Select Save;
  • Now try switching Rider windows with the shortcut set;

If it doesn't help, would you mind taking a look at this keyboard troubleshooting article ?

Have a nice day!



YES, it worked!

Thank you. That is great. I am using that keystroke a lot.

Keep up the good work!

Hello Mats,

I am happy to hear that I was able to help.
Should you have any other questions or difficulties in the future, do not hesitate to contact support.
Have a nice day!

I also encountered this issue recently. All other applications on Mac can be switched between using cmd+§, but Rider suddenly stopped doing that. IIRC this happened when I switched to the new UI, but switching back it still didn't work.

The solution posed by Dmitry here works well, and you can assign cmd+§ to that keybind as well to have coherent experience between applications.


Please sign in to leave a comment.