Using Project Rider under Linux: prerequisites

Development in JetBrains Rider under Linux will require at least one of the following additional frameworks depending on the kind of developed application:

3 comments

hi,

dnx is already deprecated & replaced with .net cli - so should rider work with .net cli too?

0

I'm running Ubuntu 16.04 with latest Mono (4.2.1) and .NET Core 1.1. When I try to open up a basic hello world project, I get the following:

 

Project 'helloworld' load failed
The lifetime has already been terminated.
Object name: 'Lifetime'.

Project 'helloworld' load failed: Can't connect to MsBuild project model process in 600000 ms

 

Any ideas on what the issue/solution could be?

2

@Brandon, You may try to update mono to 4.8 or 5.0, if it will not help, then zip and submit somewhere all logs from Help->Show log in Files folder. Follow up here.

Edited by Ivan Shakhov
0

Please sign in to leave a comment.

Have more questions?

Submit a request