Support for the .NET SDK 5.0

Rider 2020.3 supports the .NET SDK 5.0. In case you are on the older Rider version, please install the latest one build from the site or via the JetBrains Toolbox app. 

 

26 comments
Comment actions Permalink

Is Rider 2020.1 EAP7 a typo? As we're on 2020.2 EAP8 now.

0
Comment actions Permalink

Looks like RC1 is up, and I note that this article was updated today. Are there any more specifics on the 5.0 support timeline now that we have a RC? I'm most concerned with the upgrade path. Will there be a straightforward migration for projects? I'm starting a new project now and want to make the best choices.

Edited by Zaneclaes
3
Comment actions Permalink

Is there an EAP with 5.0 support? 

1
Comment actions Permalink

As above, we're only two months from the release and there is an RC candidate available so how can we get this tested within Rider?

I've installed the RC1 SDK and Rider detects the new msbuild, and I can set the project to C#9 and it builds. But there doesn't seem to be any support for the new C#9 features.

0
Comment actions Permalink

Hello everyone! 

The first EAP build of Rider 2020.3 will have initial support of .NET 5, including:

  • The first steps in C# 9 support: Top-level statements, native ints, target typed conditional expressions, static lambdas, and DynamicallyAccessedMembers attribute. 
  • Support for the new way in the NuGet restore.
  • Coverage and performance profiling work with the new SDK.
  • etc.

We are planning to open EAP this or next week. So, stay tuned!

Thanks! 

3
Comment actions Permalink

Great! Thanks for the update :D

0
Comment actions Permalink

looking forward to trying it out.  I want to upgrade a project from 3.0 to 5.0

0
Comment actions Permalink

Using the latest EAP Rider (Build #RD-203.4203.15, built on October 1, 2020)
I am getting the below errors when trying to build my solution:

```
Microsoft.PackageDependencyResolution.targets(234, 5): [NETSDK1005] Assets file ....\obj\project.assets.json' doesn't have a target for '.NETFramework,Version=v5.0'. Ensure that restore has run and that you have included 'net50' in the TargetFrameworks for your project.
```

The same exact solution builds and runs OK with VS 2019 Preview
Is there anything that can be done?



2
Comment actions Permalink

I'm getting that too, I have to manually restore my projects (dotnet restore) before building or having resharper not show a slew of errors.

The new project window also incorrectly shows.NET Framework sdk targets for the templates when using the .NET 5 sdk (e.g. ".Net Framework v4.7.2"), something along the chain incorrectly identifies TargetFramework net5.0 as a .NET Framework identifier.

2
Comment actions Permalink

Danielle thanks for the report! 

Please file a new issue here https://youtrack.jetbrains.com/issues/RIDER and attach log files (`Help | Collect Logs`) right after you get the error. 

Thanks! 

0
Comment actions Permalink

corrupt Thanks for the report! You told "ReSharper", are you sure? ReSharper uses Visual Studio to restore packages. Thanks! 

0
Comment actions Permalink

I misspoke, I meant Rider just ends up showing a lot of red because types are missing as .NET Framework 5.0 (which isn't a thing) assemblies can't be found.

0
Comment actions Permalink

As corrupt said, I'm also unsure of how to get the .net 5 reference assemblies.

I've installed vs 2019 preview, and the project builds there but nothing installed the reference assemblies into the program files directories, so Rider says "reference assemblies for .net framework v5.0 not found".

0
Comment actions Permalink

Okay, to use .net 5 SDK, you have to remember to set the MSBuild in Rider -> Settings -> Toolset And Build to the .net 5 SDK msbuild dll as noted in this comment: https://youtrack.jetbrains.com/issue/RIDER-51874#focus=Comments-27-4489700.0-0

0
Comment actions Permalink

When can we expect a release that supports dotnet 5?

3
Comment actions Permalink

Rider has worked with dotnet5 since at least EAP3. I'm currently using EAP6 with dotnet5.0 (final).

0
Comment actions Permalink

I made the mistake of installing VS2019 update last night and all my Rider installs broke (still mostly using 2020.1.4 due to outstanding major issues with 2020.2.x versions). It's impossible to uninstall VS but I keep regular backups with Shadow Protect, so I just restored my machine to an hour earlier.

However I don't really want to use the EAP to play with .net 5.0. Is there a way to get the older versions of Rider working with .net 5.0, not just the EAP? I don't need .net 5.0 features as I am more than happy to play with that using an EAP or VS2019 itself, but I need to be able to build our normal .net 4.8 code and get work done, and that all broke as soon as the .net 5.0 tools got installed.

2
Comment actions Permalink

Zaneclaes Do you use early access versions of applications for production? I am of course inquiring when rider will support dotnet 5 in its stabel version, so i can use it for production workloads.

0
Comment actions Permalink

Well I am now using EAP6 for my normal dev environment (still have not reinstalled .net 5.0 yet), and the issues I was having look to be fixed. I think 2020.3 must be getting real close to release as usually the final version ends up coming out after EAP7/8 or so.

I generally avoid using the EAP for normal dev work unless there are critical bugs in the other versions, but as long as it works for your needs, it won't affect production code builds. It uses all the tooling from Microsoft and VS anyway for the builds so it can't break that ;)

0
Comment actions Permalink

I'm using Rider, ImGui.NET and .net 5.0 without issues here.

I had to switch to MSBUILD coming from the new SDK and that's it.

Edited by Richard Lalancette
0
Comment actions Permalink

Everything seems working out-of-the-box with dotnet GS release.

 

0
Comment actions Permalink

What is about record declarations?

3
Comment actions Permalink

For anyone having issues with it complaining about needing to specify --windows in TargetFramework when using net5.0 and failing to build, change the net5.0 to

net5.0-windows10.0.17763.0

Edit: Looks like you don't need to target a specific build, and all you need is this.

net5.0-windows
Edited by Forts
0
Comment actions Permalink

Since installing .net 5, when adding a new project to an existing solution I cannot select any netcoreapp version for the target framework.  I only see .Net Framework version including a .Net Framework 5, which isn't accurate. 

When creating a new solution I have the opportunity to change the sdk.  I can set the sdk to the latest 3.1.x sdk and then I see .netcoreapp 2,x, 3.x, etc, for frameworks.

Adding new project to existing solution.

 

The other options not in seen in the ddl are more .Net framework versions, 4,6.x, 4,7.x, 4.8.

 

Is this a bug or possibly a setting that I need to switch in the IDE so I can select netcoreapp versions?

9
Comment actions Permalink

This bug is fixes with JetBrains Rider 2020.3.2
Build #RD-203.6682.21, built on December 29, 2020

0

Please sign in to leave a comment.

Have more questions?

Submit a request