Hanging Connecting to ReSharper Host on OSX

Completed

Every time I first start Rider, it hangs loading the solution with this message.  I've tried waiting a while but it never completes until I kill my network connection, at which point it loads quickly.

What is Rider trying to connect to?  It may be that my company is blocking the connection, but I'm not sure why it's related to my network connection; everything should be local.  Are there any services or local ports I should be looking at to troubleshoot this issue?

29 comments
Comment actions Permalink

Hi! Which version of Rider do you use? Does the problem persist on the latest EAP? https://www.jetbrains.com/rider/eap/

0
Comment actions Permalink

I was using 2017.1.2.  I can still reproduce the issue in the EAP.  Are there any sort of diagnostics I can run to see what's stopping it from connecting to the host? 

0
Comment actions Permalink

I'm seeing the same thing - my company has some certs that I have had to install and they sometimes cause this kind of issue - could be related?

0
Comment actions Permalink

I just downloaded Rider for the first time to experiment. I opened both an existing .NET project and created a new console application. The same behavior occurred as described by Msnyder. It stops the solutions from loading in the IDE. It could be a company firewall, but I cannot diagnose the issue. I tried to downgrade back to Rider 2017.1.2 and the issue remains. Any guidance?

0
Comment actions Permalink

Issue happens only if you work behind company firewall, where admins mocks security certificate.

I have the same at work, but not at home.

0
Comment actions Permalink

It turns out that the JB IDEs have their own certificate store. I added my company's certificates (search for "cert" in the settings) and it seems to have solved the problem for me.

0
Comment actions Permalink

I have this issue on my personal machine -- no company certificate to add. Both in 2017.3 and 2017.3 EAP.

Maybe the following is unrelated, but when I start Rider I get the following error message:
"Oops, Rider host has unexpectedly exited with exit code 1.
See <snip>/.Rider2017.3/system/log/backend-err.log. Please send it to the support too"
(the message might be cut off due to awesome WM, not sure)

backend-err.log is empty however.

0
Comment actions Permalink

Rider 2017.3 - This has just happened to me and it "seemed" to be solution related. Why I say "seemed" to be is because whilst trying to solve it I restarted the Rider solution three times, clearing the cache once and the problem remained. I even restarted my Mac. Still nothing then when the problem still didnt go away I closed Rider and opened a different solution for another 'project' and it loaded ok. It seemed a bit slow in loading but it worked. Then, with this solution still loaded I opened the problematic solution in another window. That loaded correctly albeit very slowly.

Those steps worked for me.

The only other thing I note is that I worked on this solution on another computer yesterday on another instance of Rider (Mac) and I noticed that there were errors in  one of the asp.net core View files. Syntax type errors that were in fact perfectly fine. The project seems syntax error-free now. Not sure if these things are significant but they're related.

0
Comment actions Permalink

Hi John,

Could you please send us log files after reproducing the issue? We need the whole log folder (backend.log, idea.log, threadDumps, etc.). To navigate to the log folder use Help -> Show log in Finder. You can either attach zip archive to a new Support Request or sent me an email to julia.vaseva at jetbrains.com.

0
Comment actions Permalink

Hello, I got the same problem : Rider stuck on "connecting to ReSharper host" while loading a project. It happened to all of my projects, all of a sudden, while Rider had worked perfectly fine the day before. I reinstalled Rider with no more success. I finally noticed that I also had the "Internal HTTP server disabled" error that I resolved by following the first answer here : https://stackoverflow.com/questions/19889503/android-studio-cannot-start-internal-http-server (command `netsh winsock reset` then reboot) and after that I no longer had the infinite "connecting to resharper host" problem. Don't know if it is linked to the problem of the others. I work in a Windows 10 virtual machine, inside a Mac on High Sierra.

1
Comment actions Permalink

I should probably update here: In my case it happened because I broke my timezone file and mono (I think) then failed because it couldn't initialize an object. A Rider support member debugged this on my machine and found it bravely :)

0
Comment actions Permalink

'Accept non-trusted certificate automatically' Under server certificates, seems to solve the issue for me.

2
Comment actions Permalink

I have same issue as Matthias Schlaipfer but on Windows 10. I don't understand what timezone file means. Please help me resolve the issue. Latest rider (2017.3.1). AVG antivirus (tried disabling it, not helped). Disabling network connection while in solution window waiting "connecting to Resharper host" does not help either. This is my home PC.

Issue started reproducing about 3 days ago. Almost at the same time, I started having "Powershell stopped" window when launching Unity 2017.2.1f1

0
Comment actions Permalink

I just started encountering this in Rider 2018.1.2 today (after having ran it for several days just fine).  I see some interesting tidbits about certificates, firewalls and even solution-specific problems, but nothing definitive yet.

I contacted support but no response yet.

-1
Comment actions Permalink

This I've tried that haven't worked:

  1. Restarting Rider
  2. Clearing cache folders manually
  3. Re-installing Rider
  4. Starting a new solution (works!) and then opening main solution (same error)

Things I've tried that seems to be working (fingers crossed):

  1. Move local copy of solution aside; re-clone from SCM (working so far)
0
Comment actions Permalink

In my experience, this happens when you run Rider

  1. on Mac OS
  2. behind company firewall
  3. with company-trusted, but not publicly trusted certificate. 

Go to Preferences > Tools > Server Certificates and either add your company's certificate to "Accepted certificates" or enable "Accept non-trusted certificates automatically"

 

Hope this helps.

0
Comment actions Permalink

I just updated Rider this morning and am having this issue. Here is the information provided by the "About JetBrains Rider" dialog.

JetBrains Rider 2018.3.2
Build #RD-183.5619.15, built on January 28, 2019
JRE: 1.8.0_152-release-1343-b26 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.2

And here is a screenshot with the message in the status bar. Tried the "Accept non-trusted certificates automatically" and that didn't resolve the issue. 

Update: It's working now. Here are the additional steps I did. 

First: I deleted the ".idea" folder for the solution and restarted Rider. Issue persisted.
Next: I did a full system reboot. That seemed to resolve the issue.

0
Comment actions Permalink

I am having the same issues with Rider 2018.3.2, now on a daily basis. Only system reboot solves it, but that is quite annoying.

Using macOS 10.14.3. When I open the Java Control Panel in the system preferences and check for updates I get a warning that it cannot check for updates. Maybe related to that?

0
Comment actions Permalink

Hello

Two days ago upgraded MacOS to Catalina and now I have the same issue. Rider hans with "Connecting to Resharper host". Can't close it. Have to Force quit only. After restarting the Mac the first load of Rider runs ok.

0
Comment actions Permalink

Hello,

Could you please collect all Rider logs via "Help | Compress Logs and Show in Finder" and share it with us in a new support request?

 

Kind regards, 

Sofia.

0
Comment actions Permalink

This is happening for me right - I tried the latest EAP too. I cannot work

1
Comment actions Permalink

2020.01 started to hang out. Can't build/debug while this hangs.

0
Comment actions Permalink

Hi Szymon Walkowski, Jordan,

Please collect all Rider logs via "Help | Compress Logs and Show in Finder"  and share them with us in a new support request.

 

Sofia.

0
Comment actions Permalink

Have the same problem.

When opening a solution Rider "connecting to resharper host" never stops. When I close the solution my CPU is still working at it's maximum. Then I want to close Rider and it says "You have a background task running. Are you sure you want to stop them and exit JetBrains Rider?".

What is happening?

I have a Xamarin Forms solution. it happens when I add the following line into a XAML:

x:DataType="{x:Type firstNavigationLevel:FirstNavigationLevelViewModel}"

 

0
Comment actions Permalink

Hi Max,

It is hard to say what is happening without any troubleshooting information.

Could you please

1) open logs folder via "Help | Diagnosting Tools | Show Log in Finder"

2) reproduce the issue once again,

3) then collect all Rider logs and attach them to the filed issue on our tracker: https://youtrack.jetbrains.com/issue/RIDER-43768.

One can restrict log visibility with the "Visible To" option.

 

Please let me know if you need assistance.

Kind regards,

Sofia.

0
Comment actions Permalink

I had the same issue with Rider for UE 2020.1.3 and I solved it by clicking on File Menu > Invalidate cache / Restart > Invalidate And restart

0
Comment actions Permalink

Same with different versions of Rider. Current  using Rider 2020.2.1. Can use Rider for one hour, after must restart mac or switch to Visual Studio.

0
Comment actions Permalink

Hi W Schaefer,

 

Please collect the logs via Help -> Collect Logs and attach them to a new issue on our tracker, so we could look into this further.

0
Comment actions Permalink

Hi, folks!

I encountered the same problem waiting for connection to Resharper.Host.

After opened backend-err.log I found and resolved the problem:

The file JetBrains.ReSharper.Host.exe was omited in <JetBrains.Rider DIR>\lib\ReSharperHost,

I added it and also JetBrains.ReSharper.Host32.exe (I run Rider on Win7 x86).

0

Please sign in to leave a comment.