Using Rider without Visual Studio documentation incorrect

Hi there,

I had to format my computer and figured I could just install Rider. I got a notification when loading a project that I required the Microsoft .NET Framework Developer Pack 4.5 from a link within the application. (https://www.microsoft.com/net/targeting) The only option available there was 4.5.2, which I installed and when rebooting Rider I received the same issue.

I then found this post: https://rider-support.jetbrains.com/hc/en-us/articles/207288089-Using-Project-Rider-under-Windows-without-Visual-Studio-prerequisites which said I could install using the Build Tools. So I installed 4.5.1 according to the bullet point below. I received the same error in Rider.

It was only when I uninstalled these and installed plain 4.5 using the Build Tools that my errors went away in Rider.

The build tools also seem to install some semblance of Visual Studio?

Thanks

Please sign in to leave a comment.