Rider Can't Find SDK


I'm trying to get APublicizer to compile for Linux with Rider but it seems unable to find my SDK. Here is proof my SDK is installed:

joshua@joshua-ubuntu:~/repositories/APublicizer$ which dotnet
joshua@joshua-ubuntu:~/repositories/APublicizer$ dotnet --list-sdks
7.0.105 [/usr/lib/dotnet/sdk]
joshua@joshua-ubuntu:~/repositories/APublicizer$ dotnet --list-runtimes
Microsoft.AspNetCore.App 7.0.5 [/usr/lib/dotnet/shared/Microsoft.AspNetCore.App]
Microsoft.NETCore.App 7.0.5 [/usr/lib/dotnet/shared/Microsoft.NETCore.App]

But Rider won't see it:

I'm sure it's pointed at the correct thing:


Hi Joshua! 

Could you please check this workaround? Let me know how it works for you. Thanks! 


Hi Alexandra,

Thanks for the reply. I got busy and had to backburner this for a while. I tried the workaround and completely removed dotnet from my system then added the microsoft repository etc. (I think it was that way already?) and reinstalled everything. I also tried managing the DOTNET_ROOT variable. Unfortunately Rider still cannot find it.

Can I somehow just tell Rider to stop looking wherever it's looking and look where they're installed?


Hi Joshua

I'm sorry to hear it didn't help. 

There are several workarounds in this thread, including setting DOTNET_ROOT manually and updating /etc/profile.d/dotnet.sh. This problem is mostly related to how you install Rider and  .NET. Do you use Toolbox? Have you tried to install Rider with Toolbox and .NET via this script? Could you check that the user account used to run Rider has permissions to traverse the tree, read and execute files in the .NET SDK installation path in your system

Also, I would like to take a look at your logs. Please upload them to our server and share the ID.



Please sign in to leave a comment.