Rider 2018.1: almost unusable

Answered

The latest version of Rider 2018.1 is pretty much unusable for me. The UI is constantly freezing every few seconds, just typing or clicking around, and everything feels so sluggish.

I had the same thing with its recent EAP, but assumed it would be fixed for the final release.

I've had to go back to 2017.3, which works fine. There is at least one other person in the office who is experiencing the same thing.

I'm on Windows 10.

20 comments
Comment actions Permalink

I'm getting the same issue but it seems to happen whenever coming back from Unity after running. I'm currently using Unity 2017.3.1

EDIT: My issue has been solved: https://youtrack.jetbrains.com/issue/RIDER-15909

0
Comment actions Permalink

I have to run even more "Invalidate cache and restart" than in previous versions. Otherwise the autocompletion just won't start working again. Pretty basic stuff that makes us consider switching to VS again.

The freezing i just encountered once so far.

0
Comment actions Permalink

Hi all,

Thanks for your feedback! We would appreciate it if you could collect the logs after issue appears as described here and attach it to a new issue on YouTrack. Please post links to the YouTrack issues here. We'd be happy to investigate and fix it.

Thank you!

0
Comment actions Permalink

Hi Julia,

Thanks for the reply, I've gone ahead and created a new issue on YouTrack, the link is bellow.

https://youtrack.jetbrains.com/issue/RIDER-15909

Regards,

Thomas

0
Comment actions Permalink

Hello

If you are developing with WPF technology, you must disable the XAML Preview in the options (Tools -> XAML Preview).

Indeed, every time you change the XAML file, Rider regenerates the preview which gives the freezes and makes the software unusable.

Regards,

1
Comment actions Permalink

I'm on OSX and I'm having the same problem. It just randomly freezes and sometimes I have to completely reboot my computer. Seems to happen even when Unity is closed. The freezing coupled with the lag I feel when typing is pushing me back to Sublime :/

0
Comment actions Permalink

@Whiskey XAML previewer works on the background and mustn't slow down the UI. We are very interested to diagnose and fix this issue! Could you please create a screencast of the freeze and collect Rider logs right after it as described here?

 

You can attach the screencast and logs to a new issue on YouTrack (an account required), or to a new support request.

Thank you!

0
Comment actions Permalink

@Brock We'd be grateful if you could take the following steps to collect Rider logs:

  1. Enable additional log categories: go to Help -> Trace Scenarious (LOGS) and check the following scenarios: modules, completion, documents, editors, projectModel, actionsPopups, searchAndNavigation.
  2. Wait until the issue reproduces and Rider gets unresponsive or laggy
  3. Open Help menu and select "Show log in Explorer", or if you cannot access Help menu see this article
  4. Zip the whole log folder (threadDumps, backend.log, idea.log, etc.) and attach it to a new issue on YouTrack (an account required), or to a new support request.
  5. Disable additional log categories

Thank you!

0
Comment actions Permalink

@Julia Vaseva

Done, hoping it can help.

Regards.

https://youtrack.jetbrains.com/issue/RIDER-16994

 

0
Comment actions Permalink

Any update on this? I have to quit Rider multiple times a day to make sure it doesn't use all the memory on my system and freeze everything. If I don't catch it in time I have to hard reboot. Since moving to 2018, development has been painful.

0
Comment actions Permalink

Any update on this? My Rider is using up to 5GB of ram. 2.5GB only with Resharper

0
Comment actions Permalink

I have the same problem with 2018.2.3. When I type comments, the editor freezes every 5 seconds. It is extremely frustrating, and honestly, I don't have time to send logs etc. Private bytes for Rider 2GB, for R# Host 1.2GB.

I would be curious to know if your developers use Rider to develop for .Net.

5
Comment actions Permalink

2018.3.1 - also having performance problems. In a separate process there's a webpack compiling pretty heavy application in watch mode. Adding its output folder to index and then excluding it from there seems to fix problems until restart.

1
Comment actions Permalink

2018.3.2 — Just gave a try, it's so terrible slow on my machine I can barely open new Unity project with 5 files 5-10 LoC each (just class name, namespace and a couple of using statements, nothing else). It destroys CPU cooler on my mac. I've even disabled ALL plugins including Unity support. No luck.

In the same time latest RubyMine works like a charm with really big projects with millions LoC on ruby, css, js and typescript at the same time. Usually I keep like 2 or 3 projects opened in different windows without any notice about performance drop.

"Almost unusable" was an overstatement. It's just unusable at all.

3
Comment actions Permalink

Hello @Mur Mailbox!

Please, check "Preferences | Languages & Frameworks | Unity Engine" -> [ ] "Parse text based assets files for implicit script usages." If it is enabled, try to disable. Does the problem persist after that?

If so, could you please collect data which was requested here?

Also, in case you see that  mono-sgen CPU usage spikes up too much, please take the following steps:

  1. Make sure that performance problem persists
  2. Collect several backend thread dumps in short intervals with "Help -> Create Backend Thread Dump" action


Create a new issue in Rider issue tracker. In the issue, provide a short description of the performance problems you're experiencing and provide the thread dumps with zipped Logs  (Help | Compress Logs and Show in Finder)

 

0
Comment actions Permalink

Hi there, FYI this is still happening with Rider 2020.1.3 and Unity 2018.4.12 on MacOS.
Moreover, I notice this happening with other versions of Unity as well. 

 

The RAM consumption from Rider is mental, more than 1Gb for the Rider process but the "dotnet" one goes up to a crazy 5Gb!

After unchecking the box as suggested by Sofia Byzova I notice dotnet process dropping down to a "reasonable" 900Mb and the UI went back to a normal behaviour (i.e. you type and the code competition works).

Help?

1
Comment actions Permalink

Hi Chiodini Dev,

Could you please clarify how big is your project and the approximate size of all of your assets files? There is a shell script for counting all unity files: https://gist.github.com/citizenmatt/605850e97cf0c3a45fc5e137f8d953a7. One can install PowerShell on macOS as well: https://docs.microsoft.com/en-us/powershell/scripting/install/installing-powershell-core-on-macos?view=powershell-6.

If you are willing to run this script, please share its output with us.

0
Comment actions Permalink

Hi Sofia Byzova this is the result of the script.

This is not even the biggest project I worked on but there is something in that checkbox that is continuously doing stuff.

By the way, what is doing that parsing? It is not clear to me the functionality of it (and other config parameters). Is there a documentation?

 

Cheers,

Diego

 

Count Name    Total Size

----- ----    ----------

2085 .asset   493733183

  296 .prefab   10683290

   11 .unity     1953006

 

0
Comment actions Permalink

Hi,

Thank you for the information.

Could you please try Rider 2020.2EAP: https://www.jetbrains.com/rider/nextversion/. There are lots of Unity optimizations that were made in it.

Please let me know about the results.

As for the parsing, Rider parses all that files for integration with assets (refactorings, find usages of scripts, methods, variables, and their values).

You might want to check out the page on GitHub: https://github.com/JetBrains/resharper-unity/wiki/Asset-serialization-mode.

0

Please sign in to leave a comment.