Unable to view DevOps TFVC repository/history

I have just installed a trial version of Rider to test out and am having issues getting the version control hooked up to our company's Azure TFVC repo.

I have followed the steps outlined in the https://rider-support.jetbrains.com/hc/en-us/articles/115001583664 

I have manually accepted the eula 

Under Settings > TFVC command line client path [Test] passes:

"Valid TF executable found"

I then followed the steps here to use my local VS workspace. https://rider-support.jetbrains.com/hc/en-us/articles/360000335099-How-to-use-Visual-Studio-s-TFV%D0%A1-local-workspace-in-Rider 

I see my VS workspace listed under VCS > TFVC > Manage Workspaces after doing all the authentication stuff so that seems okay too.

The Version control tab in rider is just showing "updating" with a spinning icon none of my local solution changes are being displayed. If I right-click solution > TFVC > Show history i see a message:

"Problems while loading file history: HTTP 401 Unauthorized"

The Version Control Window > Repository tab is blank and continually says "Refreshing VCS history"

I also keep getting prompted to set the VCS History Cache Settings and always select 500 but it doesn't seem to save.

 

I did notice my Settings > Version Control > Azure DevOps Services / TFS screen is empty. In that there are no records in the grid but also no way to add a new record.

 

Any help would be appreciated it 

 

 

1 comment
Comment actions Permalink

Hi David,

Could you please clarify the exact command you performed in cmd (tf.cmd workspaces /collection:<collection-url>)?
Also, please share full idea.log (Help | Show Logs in Explorer) file. 
You can upload the requested information via submitting a new support request https://rider-support.jetbrains.com/hc/en-us/requests/new?ticket_form_id=97145.

Thank you!

 

Kind regards,

Sofia.

0

Please sign in to leave a comment.