JIT Debugger Launcher Window not showing up

I'm trying to debug a windows service and have Debugger.Launch() in the code.  I have Rider JIT Debugger registered as the system debugger following steps in other articles.  Specifically using : File > Settings > Debugger 

 

 

My issue is that NOTHING happens.  No window, no attach prompts, nothing.  Using powershell i can see that some JIT debugger stuff seems to be trying to run but nothing is showing up.  

I can't seem to figure it out.

 

7 comments
Comment actions Permalink

Hello,

Could you please clarify what action you run to start your program? What is your Rider version?

Can you reproduce this behavior on a simple console application?

class Program
{
    static void Main(string[] args)
    {
        Debugger.Launch();
        Console.WriteLine("Hello World!");
        while (true)
        {
            Console.Write(".");
        }
    }
}

Please create it and insert the code above, then run the app by pressing the "Run" button (not the "bug" button) and let me know about the results.

 

kind regards,

Sofia.

0
Comment actions Permalink

I just tried this.  The app runs - console shows tons of dots..... NO deubbugger launched

 

0
Comment actions Permalink

Also I'm using latest version 2020.1.4

0
Comment actions Permalink

I do see this exe running in the background: RiderJITDebuggerLauncher64.exe

But it never pops up / prompts me. 

0
Comment actions Permalink

Please try the following:

1.  On the settings page "File | Settings | Build, Execution, Deployment | Debugger," press "Restore Previous default debugger" and then save settings.

2. Open this settings page again and set Rider as a Default Debugger, save settings.

3. Check if it helps to solve the issue.

4. If it persists, go to "C:\Users\heath\AppData\Local\JetBrains\Rider\JITDebugger\" and let me know about what is inside this folder.

0
Comment actions Permalink

I've unset and reset the global debugger several times both as my user as as "Run as Admin"  and the behavior never changes.

 

I have restarted between each step as well.  No JITDebugger folder at all.

 

 

0
Comment actions Permalink

Thank you for the information.I've filed an issue and assigned it to a dedicated developer: https://youtrack.jetbrains.com/issue/RIDER-48414.

Please enable "Debugger" tracing in the menu "Help "| Diagnostic Tools | Chose trace scenarios", then reproduce the issue, collect all logs via "Help | Collect Logs", attach them to the issue on youtrack, and disable tracing.

Als, please try Rider 2020.2 EAP https://www.jetbrains.com/rider/nextversion/ and check if it has this issue.

Thank you in advance.

0

Please sign in to leave a comment.