No Rider IDE option in UE 4.27.1

Answered

Hello!
I've just installed Rider for Unreal but, I can't find Rider in the source code editor section.
I've installed RiderLink plugin in the engine but, nothing happens
Does someone have an idea?

 

8 comments
Comment actions Permalink

Hello Thomas Colinleco,

Could you check if the "Rider Integration" plugin is enabled in the Unreal Editor?

0
Comment actions Permalink

Hey Kirill !

Yes both plugins are enabled

0
Comment actions Permalink

Could you check if you are using the latest available build of Rider for UE? You should see the following build number under Help->About: "Rider for Unreal Engine 2021.2.1 Build #RDCPPP-212.5080.85, built on October 5, 2021"

0
Comment actions Permalink

Yes it's the last one

1
Comment actions Permalink

Thank you for the information Thomas Colinleco!

Looks like there might be an issue with the Rider installation or the registry access.

"Rider Integraton" plugin searches for the valid Rider installations via registry lookup. It looks for Rider-related InstallLocation values in the following locations:

  • HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
  • HKEY_CURRENT_USER\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall
  • HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall

As an example, an installer can write the following key to the registry:

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\Rider for Unreal Engine 2021.2.1

InstallLocation = C:\Program Files\JetBrains\Rider for Unreal Engine 2021.2.1

 

If the lookup fails, Rider for UE will not be available as a source code editor in UE.

 

Would you mind checking if the registry keys are present on your system? If the registry values are missing please try reinstalling Rider (the installer will try to write the necessary values to the registry).

 

In case the reinstall does not help or if you want to avoid reinstalling Rider, you can configure the path to Rider for UE executable manually by editing the {UE installation directory}\Engine\Plugins\Developer\RiderSourceCodeAccess\Resources\RiderLocations.txt file.

 
1
Comment actions Permalink

Thanks a lot!
I've added Rider's installation path in RiderLocation.txt and, it works :)

1
Comment actions Permalink

After configure path to Rider manaully, still doesn't work:

{UE installation directory}\Engine\Plugins\Developer\RiderSourceCodeAccess\Resources\RiderLocations.txt file.

1
Comment actions Permalink

Hello 9902699141a,

Please generate a log archive using Help->Collect Logs and send it to us via a support request (Help->Contact Support) so we can look into this issue further.

0

Please sign in to leave a comment.