No markdown preview buttons after trying New UI



Today I tried the New UI. While I liked it, I noticed that I can not see the preview in markdown files (it displays 404 errors). I disabled the New UI and tried to see if the preview works but I noticed that the 3 icons that usually appears when I move my cursor to the upper right side of the editor to select preview mode (editor, editor with preview and preview) are not showing. I can double shift and select the right action to show the mode I want and then the preview is displayed correctly but I can only use actions to switch between modes, not buttons.

Once this happened I was trying to look for other issues and I noticed that the three pencils at the bottom right which I once used to select error level are displayed but I can not interact with them.

I'm not using rider often so I may overlook something but at least the markdown preview buttons used to work until a few days ago.

Any Ideas? 

I'm using rider 2022.3 on windows 10 22H2.





After updating to Rider 2022.3.1 New UI does preview markdown so I can go back to New UI. However when trying to go back to regular UI the behavior is the same as described above 🙁.


Hello Haim, thank you for your message. Could you please reproduce the issue and collect the full log bundle so we could take a closer look at the case? Please upload log files manually to JB server via form. Thank you in advance and have a great day!


Thanks Maria Pleskunina, I didn't work on Rider for a couple of weeks, today I started Rider, performed some plugin updates, disabled the New UI and ...

Everything works correctly 🙂. Not sure what has changed but I'm glad that it works.

Thanks you very much




Happy to hear that everything is working fine for you now! Please feel free to contact us in case of any other questions. Have a nice day :)


Please sign in to leave a comment.