Rider 2022.1 on Linux doesn't find Unreal Engine source when multiple versions exist

I'm using Rider 2022.3.1 on Linux. When I try to open a .uproject I get this error.
I've tried to:

-look at the $HOME/.config/Unreal\ Engine/install.ini, but the file didn't exist

-add an install.ini file following that
-open the project with the unreal version selector

I've read the following:

-RIDER-75402

-Rider 2022.1 on Linux doesn't find Unreal Engine source when multiple versions exist

15 comments
Comment actions Permalink

Hello,

Thank you for contacting Rider support.

I suggest trying the following options:

  • Call the {Engine}/Setup.sh from terminal and ensure it prints no errors;
  • Check the $HOME/.config/Unreal\ Engine/install.ini. It should contain an entry to the Unreal Engine folder (a folder with Setup.sh inside). If it has no entry, try adding it as per below sample:
[Installations]
InventYourGUIDIfThereIsNoSuchEntry = /Path/To/Engine
  • Open the .uproject file for edit and check the EngineAssociation. If it doesn't match to GUID from install.ini file, amend it.
  • Now try to open the .uproject from Rider;

As an extra option, open the {Engine}/Default.uprojectdirs in Rider and build the engine, ensure that you can launch the Unreal Editor via Run button in Rider.

If it doesn't help, please share a screenshot that demonstrates the error you encounter and let me know the exact version of Unreal Engine you downloaded.

Have a nice day!

0
Comment actions Permalink

I'm using unreal engine 5.0 built from source using the 5.0 branch on GitHub.
I've Run the Setup.sh script but it didn't create install.ini in $HOME/.config/Unreal\ Engine/install.ini.
I've tried to create an install.ini file and put my Engine folder like you showed but didn't work either.
I've successfully opened the {Engine}/Default.uprojectdirs and opened unreal with the Run button.
I then installed the rider plugin into the engine (using the Languages and Frameworks tab in Rider's settings). When I opened Unreal I can see both RiderLink and Rider Integration in the plugin list, but can't select Rider in the editor preferences.
And When I open a .uproject still the same error

0
Comment actions Permalink

Not sure if you've figured it out already but for me Install.ini is located at ~/.config/Epic/UnrealEngine/Install.ini. You may want to look there for the engine guid.

0
Comment actions Permalink

Thanks for your answer, I was able to find the install.ini file in ~/.config/Epic/UnrealEngine/.

I've checked the engine guid in the file and uproject even if there were the same still the same error in Rider. I've also added a new entry in the file: test=/path/to/engine and modified the uproject but didn't work either.

0
Comment actions Permalink

Hm, just to make sure. Your Install.ini looks something like this?

[Installations]

00000000-0000-0000-0000-000000510010=/path/to/engine_10
00000000-0000-0000-0000-000000510011=/path/to/engine_11

Sometimes guid will be surrounded by { }, delete those. Also, it may not be important but do not add spaces around =. Once you have that, your .uproject should reference the engine like this:

"EngineAssociation": "00000000-0000-0000-0000-000000510011"

As far as I remember this was all I had to do to make Rider see my engine versions.

0
Comment actions Permalink

I've removed the {} but still has the same error.

0
Comment actions Permalink

Hm, this looks perfectly fine. I wonder if maybe some of your configuration files are wrong ( like a missing comma ). Is this perhaps an empty test project you can share?

0
Comment actions Permalink

Here is an empty project that works for me. I just made it, it's just few standard files ( ~6KiB ). Extract it, update .uproject with your engine guid and point Rider at it. This should rule out some of the potential issues. https://file.io/JBUrhT31uC57 

0
Comment actions Permalink

Same Error

Failed to locate Unreal Engine associated with the project file. Make sure the EngineAssociation field in SweetRoll.uproject has a correct value. Alternatively, right-click SweetRoll.uproject, choose 'Switch Unreal Engine version…', and specify the desired version of Unreal Engine.

0
Comment actions Permalink

Hm, is Rider installed as flatpak? It never worked properly for me when installed that way.

1
Comment actions Permalink

Yes, I'll test another version then

0
Comment actions Permalink

I uninstall the flatpack version and downloaded it directly from JetBrains, and now it works.
Thanks for the help.

0
Comment actions Permalink

No problem : )

0
Comment actions Permalink

Hello Bugg,

Thank you for your help in solving Gameflaves problem.

Hello Gameflave,

I am happy to hear that we came up with a solution. Flatpak is not an officially supported channel for JetBrains IDEs installation. We can't guarantee that installing Rider IDE from Flatpak is a safe and working method. If you are interested in Flatpak support, feel free to upvote this issue.

Should you have any other questions or difficulties, do not hesitate to contact support.

Have a nice day!

0

Please sign in to leave a comment.