Rider for Unreal Engine keeps caching my project every time i start it

Every time i open Rider for Unreal Engine it likes to cache my whole project again. This uses 100% of my ram and cpu (32gb ram and i9-9900KS cpu)

 

Is there a way to turn caching off or limit it in some way? I wouldn't mind it's caching but my whole pc is unusable during the few hours it takes.

13 comments
Comment actions Permalink

Hello,

Rider is definitely not expected to behave like this. Would you mind creating a support ticket for this case? Please collect Rider logs as described here and attach it to the ticket. Thank you in advance!

0
Comment actions Permalink

Hi, it happens to my end every time I switch branches. Right now my only solution is to close Rider before switching branch. But if I forgot to close it, cache will be invalidated and recache.

 

Is there any way to disable this process because it is awfully slow on large projects.

1
Comment actions Permalink

Hi Jeff Jadulco,

 

Please collect the Rider logs after switching branches via Help->Collect Logs and submit them as a part of a new support request (Help->Contact Support).

0
Comment actions Permalink

Me too. It happens after I upgrade R4UE to 2020.3. It takes too much time and memory.

1
Comment actions Permalink

Hi 1119369173,

Would you mind trying the recently released Rider for Unreal Engine 2021.2 and letting us know if you still experience this issue?

0
Comment actions Permalink

I want to bump this, even with 2021.2, it takes a good 5 minutes every time I open rider before I can do anything. Im on a 7700HQ with 16GB of RAM and every time I open rider, it takes ages to invalidate and reanalyze unreal engine source files - which it does on every opening.

This is more important to me on my laptop which has limited cpu power and battery life when compared to my threadripper desktop.

0
Comment actions Permalink

Hello Marstaik,

This behavior looks like a bug. Would you mind collecting and sending us some additional information that we could use to investigate the issue?

  • Use Help->Diagnostic Tools->Choose Trace Scenarios action and pick CppCaches scenario
  • Reproduce the problem
  • Use Help -> Report a Bug shortly after reproducing the problem. Agree to attach logs, leave a short description of this issue or a link to this thread and specify the engine version you are using (for example, UE 4.27 build from Epic Games Launcher or UE 5 build, branch ue5-main from GitHub).

Let me know if you encounter any issues. Thank you!

0
Comment actions Permalink

I have the same problem. If you re-generate the .sln file, then after it is launched, the engine will be indexed again

0
Comment actions Permalink

Hello Lexa Merkylov99,

 

Would you mind trying Rider 2022.2 that will be released within a couple of weeks? This version should index the engine only when necessary and significantly speeds up initial indexing compared to 2022.1. 

If you don't want to wait, you can try EAP build that can be downloaded using this link.

 

Let me know if you encounter the same issue with Rider 2022.2

0
Comment actions Permalink

Kirill Filin Checked in early access, the engine is still indexed after generating .sln

0
Comment actions Permalink

Hello Lexa Merkylov99

Sorry to hear about this issue. Would you mind collecting Rider logs with additional tracing scenarios enabled so we can investigate this issue further?

To collect the logs, please:

  • Use Help->Diagnostic Tools->Choose Trace Scenarios action and pick CppCaches scenario
  • Reproduce the issue (regenerate the .sln and reopen project in Rider, wait until Rider finishes reindexing the engine)
  • Collect Rider logs (Help->Collect Logs) and disable the tracing scenario
  • Use Help->Contact Support and attach the generated log archive to the request. Please mention this thread when submitting a request.

Let me know if you have any questions.

0
Comment actions Permalink

No worries, thank you for letting us know. Feel free to contact us if you have any questions or encounter any issues.

0

Please sign in to leave a comment.