UE5 Breakpoint will not currently be hit.

UE5, Win10 (x64)

Hello! I have a project with GAS Companion and Twisted Bytes Interaction System plugins. They use the Ability System. TBIA akso have an integration tutorial which I've followed to bind these plugins. 

So I have:

UTBIA_AbilitySystemComponent : public UGSCAbilitySystemComponent
UGSCAbilitySystemComponent : public UAbilitySystemComponent

 

The problem is GSCAbilitySystemComponent has a function:

FGameplayAbilitySpec* UAbilitySystemComponent::FindAbilitySpecFromGEHandle(FActiveGameplayEffectHandle Handle)

I have an Actor which has TBIA_AbilitySystemCompoent and I get it and trying to call this function but for some reason it's not being called.

I set a breakpoint inside this function and build the project and Rider says that it won't be hit (see the image):

When I used only GAS plugin that part of the code (where I call the function) worked fine. But when I integrated TBIA it stopped working. 

See the image below of the code where I try to call the function. The yellow part I marked is never been triggered because the AbilitySpec variable is always NULL

I've checked this thread and the solution did not help.

2 comments
Comment actions Permalink

I've made a test project to try out (named MyProject). Copied 3 plugins I'm having troubles with (copypasted). And it all worked fine. I've compared .uproject and .build.cs files of my initial project (Project_2) and MyProject to find any issues but didn't noticed any (pic 1, 2):

 

Also in the MyProject, Rider is able to go to the definition of the GameplayAbilities.uplugin by clicking Ctrl+LMB on the .uproject tab. In Project_2 it says "Cannot find declaration to go" (pic 3):

Also, highligthted areas show this (pic 4):

I beleive that is the problem but don't know how to fix that. The question is how to make Rider or UE be able to find and go to the declaration of .uplugin?

0
Comment actions Permalink

Hello Timdogger,

Thank you for contacting Rider support.
Apologies for keeping you so long without an answer.

Would you mind trying the following options?

  • Ensure that File | Settings | Languages & Frameworks | C++ | Unreal Engine | Index third-party code, Index plugins are enabled; Then invalidate solution caches via File | Invalidate Caches and restart Rider;
  • If you open your game project via .sln file, please try opening it via .uproject file(File | Open | Open | select {gamePath}/{game}.uproject);
  • If it doesn't help, I suggest trying the recently released version of Rider 2022.3 as we add a significant number of fixes and performance improvements with each release.

I will be waiting for your response.
Have a nice day!

0

Please sign in to leave a comment.