Project template missing in Rider 2017.3 Ubuntu



Am new to Rider, While on start up I have seen option to create solution. But there I couldn't find any option to create .net core project or any project. And always showing syncing project templates. Am I missing something here ?






Wake up support team!


I have the same problem. The oldest Rider works fine but new Rider can't read any predefined templates from dotnet.



Could you please collect the logs as described here and attach it to a new YouTrack issue or a Support Request? We'll investigate what's going on.




I have updated to ubuntu bionic.

Have a look at this error log:

Warning: No JetBrains.ExternalAnnotations packages found in the host ReSharperHost12
Value cannot be null. Parameter name: value

--- EXCEPTION #1/2 [ArgumentNullException]
Message = “Value cannot be null.”
ExceptionPath = Root.InnerException
ClassName = System.ArgumentNullException
Source = JetBrains.Platform.RdProtocol
ParamName = value
StackTraceString = “
  at JetBrains.Rider.Model.RdStringPair..ctor (System.String name, System.String value) [0x00017] in <512e8a42096b4d2e9046a8ad60d15f58>:0
    at JetBrains.ReSharper.Host.Features.ProjectModel.ProjectTemplates.DotNetTemplates.DotNetTemplatesMatcher.GetDiagnostics (Microsoft.TemplateEngine.E
dge.Settings.TemplateInfo info) [0x00027] in <c2b4ce401bb14246976ea513f1d2c310>:0
    at JetBrains.ReSharper.Host.Features.ProjectModel.ProjectTemplates.DotNetTemplates.DotNetTemplatesMatcher.Match (Microsoft.TemplateEngine.Utils.Engi
neEnvironmentSettings settings, System.Collections.Generic.List`1[T] templateInfoList) [0x0015d] in <c2b4ce401bb14246976ea513f1d2c310>:0
    at JetBrains.ReSharper.Host.Features.ProjectModel.ProjectTemplates.DotNetTemplates.DotNetTemplatesIntergation.LoadTemplates (System.Collections.Gene
ric.IReadOnlyCollection`1[T] sources) [0x000d1] in <c2b4ce401bb14246976ea513f1d2c310>:0
    at JetBrains.ReSharper.Host.Features.ProjectModel.ProjectTemplates.ProjectTemplatesHost+<>c__DisplayClass3_1.<.ctor>b__2 () [0x00000] in <c2b4ce401b
    at JetBrains.Util.ILoggerEx.Catch[TValue] (JetBrains.Util.ILogger thіs, System.Func`1[TResult] F, JetBrains.Util.ExceptionOrigin origin, JetBrains.U
til.LoggingLevel loggingLevel) [0x00060] in <686ba25a59194fd5b52c26390c880580>:0

--- Outer ---

--- EXCEPTION #2/2 [LoggerException]
Message = “
  Value cannot be null.
  Parameter name: value

ExceptionPath = Root
ClassName = JetBrains.Util.LoggerException
InnerException = “Exception #1 at Root.InnerException”
HResult = COR_E_APPLICATION=80131600
StackTraceString = “
  at JetBrains.Util.ILoggerEx.LogException (JetBrains.Util.ILogger this, JetBrains.Util.LoggingLevel level, System.Exception exception, JetBrains.Util.E
xceptionOrigin exceptionOrigin, System.String comment) [0x00000] in <686ba25a59194fd5b52c26390c880580>:0
    at JetBrains.Util.ILoggerEx.Catch[TValue] (JetBrains.Util.ILogger thіs, System.Func`1[TResult] F, JetBrains.Util.ExceptionOrigin origin, JetBrains.U
til.LoggingLevel loggingLevel) [0x00000] in <686ba25a59194fd5b52c26390c880580>:0
    at JetBrains.Util.ILoggerEx.Catch[TValue] (JetBrains.Util.ILogger thіs, System.Func`1[TResult] F, JetBrains.Util.ExceptionOrigin origin) [0x00000] i
n <686ba25a59194fd5b52c26390c880580>:0


Helmut Huber Seems that you have .net core 2.1 SDK installed. This bug is fixed in the latest Rider Nightly build, see A how-to for getting Rider Nightly build is here:


Hello JetBrains Community! First post here so I hope I'm doing this right!

I know this is an old topic, however I had the same issue on macOS, and due to the similarities between the two operating systems I thought I might chime in if the latest Rider version doesn't help you. I've included a TL;DR at the bottom in case you just want this fixing. I'm using Rider 2018.2 and could find no help online, but after a while I got it to work.


Long Version

I had opened Rider using the 'sudo' command in order to create a process that can access protected ports, which seemed to have broken the Rider installation. My fix was as follows:

  1. Close all copies of Rider on all user accounts (I believe it won't let you update permissions without doing this so if it isn't working make sure that all Rider processes have ended using your task manager/activity monitor!)
  2. Open a terminal as your current user (MacOS: CMD+Space then type "terminal", Ubuntu: press and hold "CTRL + ALT + T" while sitting at the desktop)
  3. Change directory to '~' (the user home) (you don't have to do this but it might help you understand if you aren't familiar with terminal. You can move to this directory by typing "cd ~")
  4. The 'ls -a' or 'dir -a' command should show a '.templateengine' directory in this folder. This is the directory that I believe Rider reads the templates from, or that Rider will look for if it exists and being unable to access it may disrupt the template discovery process - I'm speculating here but this may help any JetBrains devs that see this.

  5. Change the permissions on this folder to something that means that a standard Rider process under your user account can access. Being lazy I simply removed all restrictions by running the following command: 'sudo chmod -R 777 .templateengine'.

If you know terminal you can skip this, however for the paranoid and security conscious, here's a breakdown of what this command means:

  • 'sudo' = run this command as the super or "root" user
  • 'chmod' = change permissions of something
  • '-R' = do this action for all subdirectories and files
  • '777' = the permission mode, in this case no restriction
  • ".templateengine" = the target directory for this operation

Restart Rider normally and try to create a new project, your templates should be restored back to this or similar: 
TL;DR Version

Running this command should fix your problem:

sudo chmod -R 777 ~/.templateengine

Important PSA: running this command as-is may cause a security risk, so use it with caution or do some more reading into chmod. This security risk presents itself in the fact that mode '777' means "everyone can read and write to this file/directory" and this problem should be self-explanatory.

I hope this helps, I know it's not Ubuntu but as I said it should be similar enough. I just discovered this solution and I didn't know where else to post it - if it's better somewhere else then I'll move it.


Many Thanks,

Ned Hyett


Worked like a charm for me, thank you friend


worked. thanks for helping out


Did not work for me. rider 2019.2.3


The bad thing, Rider does not show any error, that is very frustrating. (Running in SUDO shows regular list of templates) and in logs I see "Access to the path '/opt' is denied"


Hi Eugeniy,
This situation could appear if the root user unarchived Rider, and then another user ran it. Please check it and try reinstalling Rider.
If it does not help, please collect Rider logs and file a new support request? Also, please clarify where do you installed Rider and how (via tar.gz?).

Kind regards, 


Please sign in to leave a comment.